No more external midi after update

For bug reports only - non-bug related questions will be moved to appropriate forum.

Moderators: Corey W, Rim

Post Reply
cloudswimmer
Member
Posts: 5
Joined: Wed Apr 04, 2018 11:00 pm

No more external midi after update

Post by cloudswimmer » Fri Jul 12, 2019 12:06 am

Before the update 2.230 I had Auria Pro running a whole studio of hardware synths .. now after the update and trying everything I can think of (yes tracks are armed) can’t get Auria to trigger any external hardware synths. What happened? Back to Cubasis for now :(

IPad Pro 10”
IOS 11
RME Babyface Pro
Roland A49 Controller
Prophet Rev2
Korg Radias
Boog Model D
Moog Grandmother
Roland JD800
Roland RD700gx
Oberheim Matrix 1000
Roland JV880
Yamaha TG77

Espiegel123
Expert
Posts: 176
Joined: Tue Nov 20, 2018 2:56 pm

Re: No more external midi after update

Post by Espiegel123 » Fri Jul 12, 2019 11:13 am

Is MIDI not making it out of the interface? Do you have anything you can connect to see if the MIDI is getting out?

One test you could try would be to send the MIDI to Audiobus and have that route it out of your iPad. You could stick a midi monitor AU in the MIDI effects slot to see if the MIDI is being sent.

I just did a test and was able to route MIDI (via BlueTooth) out of my iPad from Auria Pro through Audiobus. So, if it makes it to my bluetooth that means that I could also send it out by choosing a hardware MIDI interface as the destination (from Audiobus) rather than the Bluetooth destination that I chose. It also worked directly out of AP.

To use Audiobus 3, to do this
  • launch audiobus 3
    in Auria Pro MIDI settings, enable note sending to Audiobus 3
    in Audiobus 3, go to the midi page
    add Virtual Midi Bridge as a MIDI source -- this will receive your MIDI
    you can now redirect the MIDI to any device that Audiobus can see
You could also use MidiFire to do the same thing. I don't have external MIDI hardware available to test out getting AP Midi to it directly at the moment.

cloudswimmer
Member
Posts: 5
Joined: Wed Apr 04, 2018 11:00 pm

Re: No more external midi after update

Post by cloudswimmer » Sat Jul 13, 2019 4:44 pm

Hmmm ..... well when when I set various midi channels on my Roland A49 keyboard controller I see the little icon light up in Auria when I press a key .. but nothing is coming out of the synth, so for instance my Roland JD800 is set to receive on midi channel 3, so I create an Auria midi track, click on FX and under 'Midi Control' under 'Instrument' select off, then under 'Port' select channed 3 .. under 'Input' select my interface, under 'output' select my interface, then go back to the main mixer screen and record arm the track ...... hit a key on my keyboard and nothing :(

This is what I was doing before the update and everything worked perfect. I made up an Auria template last year and call it 'Hardware Synths' All I have to do is load that template and all my harware synths are playable and ready to go with me just needing to change the midi channel on my keyboard to each hardware synths corresponding midi channel when I want to play that synth. Right after I updated Auria to this latest update I booted Auria, loaded my template as usual .. and nothing! This is very heart breaking. So Auria is now useless to me. I set up a whole second studio in this building with just the hardware synths, a mixing desk, and just my iPad to get away from the computer and its VST synths in my other studio .. and its been just fantastic .. its like working again the way we did in the 80's with Auria's simplicity.

I hope this either gets fixed soon .. or the developer can chime in and tell me whats changed that I'm missing. In the mean time Cubasis still works fine so I'm not totally stuffed .. but Auria just has had a better feel to me than Cubasis .. it reminds me of my old Opcode Studio Vision I ran on my Mac SE30 back in the 80's ..... my most productive time in the 40 years I've been doing this as both a pro and amature :)

CS

cloudswimmer
Member
Posts: 5
Joined: Wed Apr 04, 2018 11:00 pm

Re: No more external midi after update

Post by cloudswimmer » Sat Jul 13, 2019 5:40 pm

Ok fixed .. whew

User avatar
Rodolfo
Expert
Posts: 223
Joined: Sun Dec 03, 2017 5:32 pm
Location: Buenos Aires

Re: No more external midi after update

Post by Rodolfo » Sat Jul 13, 2019 6:25 pm

Hi @cloudswimmer
I just tried with a couple of hardware synths and MIDI Out is working fine for me, same as in previous versions.

Following your comments I tried to replicate your setup and noticed that if I select the same interface as input and output ports, MIDI will not be sent out to the interface. The only way is that you select “ALL” as input and your interface as Output and then it works as expected.
I tested this in both, v2.22 (previous) and 2.23 (current), and the behavior is the same, so I guess it could be related to some change in your specific setup but not in Auria Pro.

The only relevant change in v2.23 that can “affect” your setup is that you no longer need to arm the track for MIDI to work, so as soon as you select “ALL” as input port and your interface as output port the MiDI routing should work as expected (provided that the MIDI controller is transmitting in the same MIDI channel that the receiver synth is configured).

Maybe @Rim or someone can comment on the internal MIDI wiring in Auria Pro and the reasons for not having to select the same interface in both ports.

Hope this helps.

Espiegel123
Expert
Posts: 176
Joined: Tue Nov 20, 2018 2:56 pm

Re: No more external midi after update

Post by Espiegel123 » Sat Jul 13, 2019 10:40 pm

cloudswimmer wrote:
Sat Jul 13, 2019 5:40 pm
Ok fixed .. whew
What fixed it?

User avatar
Rodolfo
Expert
Posts: 223
Joined: Sun Dec 03, 2017 5:32 pm
Location: Buenos Aires

Re: No more external midi after update

Post by Rodolfo » Sun Jul 14, 2019 4:07 pm

Espiegel123 wrote:
Sat Jul 13, 2019 10:40 pm
cloudswimmer wrote:
Sat Jul 13, 2019 5:40 pm
Ok fixed .. whew
What fixed it?
I just realize that @cloudswimmer had already answered. I also wonder what the issue actually was.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest